Hello,

I was trying to implement the push notification service via Phonegap Build.

So as a strating point I downloaded the recommended app by Pushwoosh help page from GitHub https://github.com/Pushwoosh/phonegap-3-sample-app

Then I added my Pushwoosh App ID and My Google Project Number (when I used what is literally referred too as Google Project ID I get an error "invalid sender").

So I had the app packed and installed it on my device. I sent push notification and as soon as I hit the woosh button I heard the familiar beep on my phone. But here is the problem. When I pull down the top tray where my push notifications appear in my Android I only have the app name and an empty header (although I defined one). Also the logo is the Phonegap default one and not the one I uploaded in Pushwoosh. When I tap it the app open and I get an alert with a random sequence of letters and numbers, just not the text I composed for the message.

I also added these two lines of code to make sure there can be no access problem:

<access origin="*"/> <access origin="*.pushwoosh.com"/>

The only thing I could think of was that I added 0.0.0/0 as the server address in GCM when getting the API key as I had no idea what to really enter and the help page set you could enter this for test purposes.

In summary. I have sent 4 notifications. 4 times I got the notification on my phone that I had received a message 4 times it did not display properly. And in the Pushwoosh statistics it says 4 times successfully sent but never opened.

Any idea?

asked 08 Aug '14, 10:22
Ge%20Rd's gravatar image

Ge Rd
114

Hello,

I have consulted with our developers, and at the moment they are checking whether our sample works as it should.

Meanwhile, could you please try to set Android SDK in your Control panel to "Pushwoosh"? It might solve the issue.

(11 Aug '14, 09:36) Dmitry Dyudeev Dmitry%20%20Dyudeev's gravatar image

It does work now... kind of. First I did change Android SDK CTR Panel to Pushwoosh. I also set Phongeap versipn to 3.5 instead of 3.1 as the builder was constantly reminding of the outdate version.

Now I receive push notifications properly BUT as soons as I launch the app I get the following alert every time I launch the app and I don't know why:

https://drive.google.com/file/d/0B2zbibofdFovZVk3Z1Q3QU1xalk/edit?usp=sharing

permanent link
answered 18 Aug '14, 15:58
Ge%20Rd's gravatar image

Ge Rd
114

edited 18 Aug '14, 15:59

it seems that you have an alert (token) in the registration process change it to console.warn //register for pushes pushNotification.registerDevice( function(status) { var pushToken = status; /////COMMENT THIS ALERT/// ///alert(pushToken);//// console.warn(pushToken); }, function(status) { console.warn(JSON.stringify(['failed to register ', status])); } );

permanent link
answered 29 Aug '14, 15:59
jpineda's gravatar image

jpineda
111

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×445
×326
×165
×91

question asked: 08 Aug '14, 10:22

question was seen: 1,823 times

last updated: 29 Aug '14, 15:59