Hi

I'm moving all my current registered devices from my own platform to pushwoosh. I have the list of all tokens, hwid, etc... so I wrote a php to call the rest api registerDevice with the info... but it seems it does not work at all. I get 0 ios registered devices.

My php code is very simple: pwCall('registerDevice', [ 'application' => PW_APPLICATION, 'auth' => PW_AUTH, 'push_token' => 'DD-FC-02-1E-B7-5F-CA-AC-99-EAyabayaba-example-token', 'language' => 'en', 'hwid' => '01E5DEBE-yabayaba-example-hwid, 'timezone' => 3600, 'device_type' => 1 ] );

The server returns: [PW] response: [PW] info: Array ( [url] => https://cp.pushwoosh.com/json/1.3/registerDevice [content_type] => [http_code] => 0 [header_size] => 0 [request_size] => 0 [filetime] => -1 [ssl_verify_result] => 0 [redirect_count] => 0 [total_time] => 0.281 [namelookup_time] => 0.031 [connect_time] => 0.141 [pretransfer_time] => 0 [size_upload] => 0 [size_download] => 0 [speed_download] => 0 [speed_upload] => 0 [download_content_length] => -1 [upload_content_length] => -1 [starttransfer_time] => 0 [redirect_time] => 0 [certinfo] => Array ( ) [primary_ip] => 2.2.2.2 [primary_port] => 443 [local_ip] => 1.1.1.1 [local_port] => 1111 [redirect_url] => )

so no clue... what' going on? btw the ip info I replaced them here with fake info due to privacy.

asked 15 Sep '14, 17:29
creat326's gravatar image

creat326
112

Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×76
×33
×18

question asked: 15 Sep '14, 17:29

question was seen: 1,219 times

last updated: 15 Sep '14, 17:29