I am rebuilding my app and are using Unity to do this as I did the first time. When running the app I see that the device get registered but the token I see in my Debug.Log is not the same at the one stored in PushWoosh?! This is very strange. When I send a push to the devicetoken I see in my Debug.Log I get response: DeviceToken UnKnown? But if I use the devicetoken saved from the old game, same device it pushes like it should?!?!?

DeviceToken (stored in my old app): 28e978a2366932619e6fca077d573e6d3d771763a040f2dd3ca0eb8768f1fed4 DeviceToken (stored in new app ): 2faac2634718da60f697de2a721f8971e84acc1188771c20adbfa221df71f6f8

As said before, this is the same device and I am using the excat same script in both apps?

Can someone please tell me what is wrong?

Best regards Jesper

asked 26 Nov '14, 15:56
jmansa's gravatar image

jmansa
1114

It seems to be an iOS8 issue. When I am on an unit with iOS8 it registers just fine but the device token returned to the app is not the same. Is there anyway to solve this? I need to get the right device token back for storing with the user. I use it for pushes between users, e.g. when a user makes a move the other user gets an push alert.

hoping for quick solution.

Best regards Jesper

permanent link
answered 27 Nov '14, 00:12
jmansa's gravatar image

jmansa
1114

Do you have HWID for the old users? You might want to contact support to get a list of old push tokens=>HWID matches. HWID should stay the same.

(28 Nov '14, 09:56) shader shader's gravatar image

For now, to get this to work as required/expected, I had to redownload XCode 5.1.1, reference it with the xcode-select command and build for iOS7 (well... I did iOS 6.1)

This made the app/plugin provide the correct device token for me.

permanent link
answered 27 Nov '14, 12:58
ct14's gravatar image

ct14
514

Well, tried this but with no luck :-/ Seems kind of stupid that you have to go back in iOS and Xcode to make this work!? Hope there is another solution!? But thanks for the comment :-.)

(27 Nov '14, 15:28) jmansa jmansa's gravatar image

OK, have been investigating further and have seen some weird things. I have created an "empty" app to test on with only the PW SDK in it (Unity3D). When running the app on my devices (ipad2 and iphone6) I do get an deviceToken, though different than the earlier deviceID, but I get one and in my PW admin I can see my 2 devices has been registered.

Now to the weird part. When pushing these 2 devices from the admin panel or my own php script (which always has worked) no pushes is received by the devices and the 2 devices is removed in my PW admin panel?!?!? So now they are not registred anymore?

Can someone, maybe PushWoosh admin, tell me what is wrong here?!? I am only missing this part to update my app.

Really hoping for help on this and thanks in advance.

Best regards Jesper

permanent link
answered 28 Nov '14, 11:11
jmansa's gravatar image

jmansa
1114

What does push status say? you might need to check that push certificates match your provisioning profile. Gateway => Sandbox, AdHoc => Production. Also make sure "bundle ID" for push certificates matches your bundle ID in provisioning profile.

(01 Dec '14, 06:57) shader shader's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×446
×88
×49

question asked: 26 Nov '14, 15:56

question was seen: 1,090 times

last updated: 01 Dec '14, 06:57