1
1

Hi guys,

I have a premium account and so I configured iOS notifications automatically and downloaded the Provisioning profile via the link. I added the mentioned provisioning profile to my iPhone Provisioning Profiles via Xcode 5.0.2 Organizer. I followed the steps to use Pushwoosh in my iOS application.

When I run the application, I receive the following message:

Pushwoosh Error Your provisioning profile does not have APS entry. Please make your profile push compatible.

What could be the problem?

asked 04 Feb '14, 14:01
dan's gravatar image

dan
21113

edited 04 Feb '14, 14:10

Alex%20Spotar's gravatar image

Alex Spotar
3.6k6

12next »

You should check your mobile provisioning profile and make sure it contains the “aps-environment” string. If it is not there, you should recreate the mobile provisioning profile in the Apple Development Portal. However, as you are using Auto Configuration for iOS, you can select the "Make my profile compatible" option in the last step of our wizard. Make sure the “aps-environment” value matches the gateway you are using: Sandbox for “development” and Production for “production” values.

permanent link
answered 04 Feb '14, 14:09
Alex%20Spotar's gravatar image

Alex Spotar
3.6k6

edited 04 Feb '14, 14:41

I followed your instructions but still received the same error message.

(04 Feb '14, 14:40) dan dan's gravatar image

Make sure your provisioning profile is push compatible and has "aps-environment" string in it.
Make sure you sign with the correct provisioning profile. Sometimes if you have two profiles for the same App ID XCode can mess up and sign with the old one.

The recommended steps are:
1. Remove all XCode profiles (http://stackoverflow.com/questions/18923095/delete-provisioning-profile-from-xcode-5)
2. Add the one and only new profile.
3. Rebuild the app.

permanent link
answered 23 Mar '15, 08:15
shader's gravatar image

shader
3.9k7

I am also getting this same error. I've tried every way possible. Provisioning file does contain the ape-environment string... I am not using the auto config.

permanent link
answered 26 Feb '14, 05:10
brownbw's gravatar image

brownbw
111

does someone solve this issue?

permanent link
answered 01 Apr '14, 18:49
Leo%20Chen's gravatar image

Leo Chen
1

i've suffered this issue and i was able to fix it by editing the provision profile (make sure that all devices are checked in apple developer portal), after enable all devices, go to pushwoosh app config page and make that provision profile pushwoosh compatible (using pushwoosh assistant) after that download & install the provision profile from apple developer portal.

permanent link
answered 24 Apr '14, 11:16
masakre's gravatar image

masakre
11

1.3k views and there is still no answer to this problem. Can someone from Pushwoosh please directly address and solve this issue, in this thread?

permanent link
answered 20 Aug '14, 18:53
Greg_Nth's gravatar image

Greg_Nth
112

Gaaah!! Been sitting with this issue for to long now... Same issue as mentioned above... anyone of you got a solution yet?

permanent link
answered 28 Aug '14, 14:05
sebe's gravatar image

sebe
111

yes, my solution was to install an ad hoc provision profile on the device, so create an ad hoc provision file in the apple dev center, download it and open it on your test device (via email for example). After installing the provision profile the error massage no longer appeared and push worked directly.

cheers!

permanent link
answered 15 Sep '14, 14:25
client62345's gravatar image

client62345
1

Evaluating the service and I have this error as well. My Provisioning Profile does contain the aps-environment entry and my app is properly configured by following the instructions.

Is that a PushWoosh issue or am I missing something?

Thank you

permanent link
answered 20 Mar '15, 20:22
bdupuis_hibernum's gravatar image

bdupuis_hibe...
1

I had the same problem after following all steps. The solution that worked for me was to go to XCode Preferences, tab Accounts, select the correct Apple ID, click View Details... and click the refresh button with the arrow on it on the left bottom corner. This refreshed all Provisioning Profiles registered at Apple. After a clean build of the project the error went away.

permanent link
answered 29 May '15, 10:22
mvandillen's gravatar image

mvandillen
112

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×343
×90
×17
×6
×2

question asked: 04 Feb '14, 14:01

question was seen: 18,435 times

last updated: 25 Aug, 16:16