[Translate by Google Translate]

I'm doing the backend of my application with Node.js. I got set up to send messages, but when sending a message with special characters, it is not sent and does not return any error. I have already put it in the header of the request: 'Content-Type','application/json; charset=utf-8' but it did not. The character that I realized the error was that is "ê". Strange that the Postman (Google Chrome extension) message going.

asked 11 Feb '15, 09:41
Bruno%20de%20Oliveira's gravatar image

Bruno de Oli...
112

Hi Bruno,

Please contact Pushwoosh support to sort it out in a timely manner.

(12 Feb '15, 12:27) Benedict Benedict's gravatar image

Hi Bruno,

Please try to insert the special symbols in UTF-8 in the text itself, or use the following:

writer.write(request.getBytes("UTF-8"));

Please note that in case of using a plain JSON request, for instance, Chrome REST plugin, you will see special symbols being processed without any issues.

If it doesn't help it would be very helpful if you could provide your API request.

permanent link
answered 19 Feb '15, 09:20
Andrew_H's gravatar image

Andrew_H
3766

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×445
×91
×15

question asked: 11 Feb '15, 09:41

question was seen: 1,071 times

last updated: 19 Feb '15, 09:20