In the FAQ it says:

Make sure you remove all stale profiles during development on the device or the device might not request a new token for push notifications properly.

How is this accomplished? I am getting invalid or missing token warnings in the push history. I have double-reaffirmed my app has the right provisioing profile and the app id is configured correctly, but each time I call the api to register the same token is returned.

asked 11 Mar '15, 03:47
zenocon's gravatar image


Hi Zenocon, were you able to solve the issue?

(17 Mar '15, 09:28) Benedict Benedict's gravatar image


Please make sure that you have properly configured the gateway for your app in the Pushwoosh Control Panel - Production for Distribution/AdHoc provisioning profile and Sandbox for Development.

permanent link
answered 16 Mar '15, 12:47
Andrew_H's gravatar image



  • In manual configuration the gateway will be automatically determined depending on the push certificate you upload.
  • In Auto Configuration you are given a choice which certificate you need.
permanent link
answered 01 Apr '16, 05:26
Benedict's gravatar image


Thanks for the info, makes total sense.

(01 Apr '16, 14:50) skoch skoch's gravatar image

Where does one find the "gateway" setting?

permanent link
answered 31 Mar '16, 15:47
skoch's gravatar image


Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 11 Mar '15, 03:47

question was seen: 903 times

last updated: 01 Apr '16, 14:50