I am trying to integrate pushwoosh, but the application icon is not shown in the notification on Android Device. Device is able to receive the notification only the icon is white (no icon). I am not sure what I am doing wrong here.

Thanks, Ashwani

asked 06 May '15, 17:35
ashwanikumar04's gravatar image


Hi, have you set up the icon in the administrator panel in the Pushwoosh website?

permanent link
answered 07 May '15, 12:36
emora's gravatar image


I think it is not necessary.

(07 May '15, 12:44) ashwanikumar04 ashwanikumar04's gravatar image

For me is working and I have set up that. I didn't made anything inside the Unity project for get the icon in the notitication. I had the icon for generate the APK and that's all.

I hope that can help.

(07 May '15, 12:47) emora emora's gravatar image

Ok, where exactly do we need to configure the icon. While sending the push or while creating the application?

(07 May '15, 13:22) ashwanikumar04 ashwanikumar04's gravatar image

In the app creation inside the Pushwoosh panel.


Where PW APP ID should be your aplication id inside pushwoosh.

When sending the push notification is for showing an image inside the notification, so you dont need it now.

(07 May '15, 13:24) emora emora's gravatar image
(07 May '15, 13:31) ashwanikumar04 ashwanikumar04's gravatar image

I have made a push to my lollipop device and i got the icons in the notification.

(11 May '15, 11:50) emora emora's gravatar image
showing 5 of 6 show 1 more comments

Hello there, this is happening to me with Unity 4.6 and Android 5.0 and newer. The icon in the top bar appears like a white square. I can send the icon in the push but keeps appearing inside a white square.

Is this fixed in the latest SDK update?

permanent link
answered 10 Jul '15, 11:07
emora's gravatar image


Please read this: https://www.pushwoosh.com/programming-push-notification/android/android-faq/#lollipop-icon

How to set notification icon in Android Lollipop?

In Android Lollipop icons were changed to be white only. Therefore, if you select targetSdkVersion >= 21 in your AndroidManifest.xml Android will use alpha-channel of the icon only. See more on the behavior in Android documentation.

The system ignores all non-alpha channels in action icons and in the main notification icon. You should assume that these icons will be alpha-only. The system draws notification icons in white and action icons in dark gray. This is beyond Pushwoosh SDK control.

However, you can revert this behavior to use old style colored icons: 1. Set targetSdkVersion to 19. This automatically brings the old behavior back.


  1. Create the notification icon according to the Android guidelines. As per documentation, the system will ignore all the colors. 2.1. Name the icon as pw_notification.png and put it in res/drawable folder. Pushwoosh SDK will use this icon as default for notifications. 2.2. Alternatively, you can use Remote API and set the "android_icon" parameter value to the icon image (without file extension).

Hope it addresses your question.

permanent link
answered 25 Jul '15, 06:59
Dheeraj's gravatar image


Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 06 May '15, 17:35

question was seen: 4,419 times

last updated: 25 Jul '15, 06:59