I'm trying to set a tag for a device from Unity and I'm not getting any errors, but it's not working.

The request I sent is:

{
  "request":
  {
    "application":"APP_CODE",
    "hwid":"HWID",
    "tags":
    {
      "LastPlannedDay":1
    }
  }
}

The APP CODE is the Pushwoosh app code (same as Pushwoosh.APP_CODE).

HWID is the token I get from void onRegisteredForPushNotifications(string token)

The response I get is:

{
  status_code:200,
  status_message:"OK",
  response:
  {
    skipped:[]
  }
}

It looks like everything is ok, but the tag is not set.

PS: My apologies if this is a double post, something seems to have gone wrong.

asked 26 Aug '15, 14:11
Feranoir's gravatar image

Feranoir
111

edited 26 Aug '15, 19:02

XXXX's gravatar image

XXXX
2.2k6

I see in our logs that you send the push token instead of HWID for "hwid"

permanent link
answered 26 Aug '15, 15:44
XXXX's gravatar image

XXXX
2.2k6

edited 27 Aug '15, 07:10

Thanks.

I tried to find how to get the HWID, appearently I got it wrong.

How do you get the HWID for Android/iPhone/Windows Phones? I can't seem to find any answer for this.

(27 Aug '15, 06:59) Feranoir Feranoir's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×88
×83
×37

question asked: 26 Aug '15, 14:11

question was seen: 882 times

last updated: 28 Aug '15, 04:20