Hello,

I'm trying to register my app to receive push notifications for iOS platforms (referred to the sample project hosted on the git).

I'm seeing the following error on the console in xCode (providing entire stack trace)

2015-09-07 12:01:27.716 myApp[2251:60b] [CDVTimer][splashscreen] 107.434988ms 2015-09-07 12:01:27.718 myApp [2251:60b] [CDVTimer][TotalPluginStartup] 109.347045ms 2015-09-07 12:01:27.756 myApp [2251:60b] Will show push notifications alert 2015-09-07 12:01:27.784 myApp [2251:5b03] Sending request: {"request":{"language":"en","application":"","userId":"XXXXXX","v":"3.0.2.370","hwid":"AAAAAA"}} 2015-09-07 12:01:27.850 myApp [2251:7907] Sending request: {"request":{"application":"","userId":" XXXXXX ","v":"3.0.2.370","hwid":" AAAAAA "}} 2015-09-07 12:01:27.852 myApp [2251:620b] Sending request: {"request":{"application":"","userId":" XXXXXX ","v":"3.0.2.370","hwid":" AAAAAA "}} 2015-09-07 12:01:27.853 myApp [2251:5b03] To urL https://cp.pushwoosh.com/json/1.3/getInApps 2015-09-07 12:01:27.855 myApp [2251:7907] To urL https://cp.pushwoosh.com/json/1.3/applicationOpen 2015-09-07 12:01:27.855 myApp [2251:620b] To urL https://cp.pushwoosh.com/json/1.3/registerUser 2015-09-07 12:01:28.097 myApp [2251:60b] location services authorization status has not been determined yet 2015-09-07 12:01:28.437 myApp [2251:60b] Resetting plugins due to page load. 2015-09-07 12:01:28.923 myApp [2251:60b] Finished load of: file:///var/mobile/Applications/XXXXXX/myApp.app/www/login.html 2015-09-07 12:01:39.334 myApp [2251:620b] Response "200 no error": string: {"status_code": 210, "status_message": "Request format is not valid."} 2015-09-07 12:01:39.338 myApp [2251:5b03] Response "200 no error": string: {"status_code":210,"status_message":"Application not found","response":null} 2015-09-07 12:01:39.341 myApp [2251:7907] Response "200 no error": string: {"status_code":210,"status_message":"Application not found","response":null} 2015-09-07 12:01:39.343 myApp [2251:7907] sending appOpen failed

I'm calling the initPushWoosh function in my document.ready. Looks like the application field is blank in the request but not sure how to fix it.

Any help would be most appreciated.

asked 07 Sep '15, 07:29
shantanudhankar's gravatar image

shantanudhankar
113

Did you set up Pushwoosh App Id correctly in the code?

In all the requests App Is is empty: "application":""

Make sure you call Pushwoosh Cordova Plugin "onDeviceReady" function with Pushwoosh App ID as soon as you receive Cordova onDeviceReady event.

Ex:

    pushNotification.onDeviceReady({pw_appid:"XXXXX-XXXXX"});
permanent link
answered 08 Sep '15, 08:52
shader's gravatar image

shader
3.9k7

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×445
×352
×165

question asked: 07 Sep '15, 07:29

question was seen: 1,381 times

last updated: 08 Sep '15, 08:52