I'm building an Android app using Cordova 5.3.3 and using the pushwoosh cordova plugin. I also use the SalesforcemobileSDK-plugin (https://github.com/forcedotcom/SalesforceMobileSDK-CordovaPlugin) .

Building my app works perfectly but when I run it gives me the error:

W/Pushwoosh(1913): [RequestManager] registerUser response success
I/Choreographer(1913): Skipped 54 frames!  The application may be doing too much work on its main thread.
D/PWCordovaPlugin(1913): Plugin Method Called: registerDevice
I/Choreographer(1913): Skipped 43 frames!  The application may be doing too much work on its main thread.
I/Choreographer(1913): Skipped 47 frames!  The application may be doing too much work on its main thread.
V/Pushwoosh(1913): [com.pushwoosh.GCMRegistrationService] Intent action = com.pushwoosh.gcm.intent.REGISTER
I/Choreographer(1913): Skipped 40 frames!  The application may be doing too much work on its main thread.
E/AndroidRuntime(1913): FATAL EXCEPTION: IntentService[com.pushwoosh.GCMRegistrationService]
E/AndroidRuntime(1913): java.lang.NoSuchMethodError: No virtual method getNoBackupFilesDir(Landroid/content/Context;)Ljava/io/File; in class Landroid/support/v4/content/ContextCompat; or its super classes (declaration of 'android.support.v4.content.ContextCompat' appears in /data/app/com.kone.test-1/base.apk)
E/AndroidRuntime(1913):     at com.google.android.gms.iid.zzd.zzdp(Unknown Source)
E/AndroidRuntime(1913):     at com.google.android.gms.iid.zzd.<init>(Unknown Source)
E/AndroidRuntime(1913):     at com.google.android.gms.iid.zzd.<init>(Unknown Source)
E/AndroidRuntime(1913):     at com.google.android.gms.iid.InstanceID.zza(Unknown Source)
E/AndroidRuntime(1913):     at com.google.android.gms.iid.InstanceID.getInstance(Unknown Source)
E/AndroidRuntime(1913):     at com.pushwoosh.GCMRegistrationService.register(Unknown Source)
E/AndroidRuntime(1913):     at com.pushwoosh.GCMRegistrationService.onHandleIntent(Unknown Source)
E/AndroidRuntime(1913):     at android.app.IntentService$ServiceHandler.handleMessage(IntentService.java:65)
E/AndroidRuntime(1913):     at android.os.Handler.dispatchMessage(Handler.java:102)
E/AndroidRuntime(1913):     at android.os.Looper.loop(Looper.java:135)
E/AndroidRuntime(1913):     at android.os.HandlerThread.run(HandlerThread.java:61)

I discovered that this is probably because I use the cordova platform android@3.6.4 and not the latest android@4.0.0. When I use the latest platform (android@4.0.0) I get these errors:

CordovaWebViewClient cannot be resolved to a type
The constructor SalesforceIceCreamWebViewClient(SalesforceDroidGapActivity, CordovaWebView) is undefined
The import org.apache.cordova.CordovaWebViewClient cannot be resolved
The method getSettings() is undefined for the type CordovaWebView
The method makeWebViewClient(CordovaWebView) of type SalesforceDroidGapActivity must override or implement a supertype method

Someone also encountered this problem? Any ideas what I have to do? Thank you!

asked 15 Oct '15, 09:54
evifavaits's gravatar image

evifavaits
113

edited 15 Oct '15, 12:51

You need to update your Android SDK to include the latest Android Support and Google Play Services libraries.

permanent link
answered 19 Oct '15, 21:23
shader's gravatar image

shader
3.9k7

Hello,

I have already updated SDK and then try to re build and as well as i have also tried to re add platform but still same error. Can you help me. For more please see below link.

http://stackoverflow.com/questions/34564203/phonegap-pushwoosh-plugin-registerdevice-app-crash12

permanent link
answered 11 Jan '16, 11:56
mayurloved's gravatar image

mayurloved
112

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×446
×326
×190
×30

question asked: 15 Oct '15, 09:54

question was seen: 1,451 times

last updated: 11 Jan '16, 11:56