I am trying to using pushwoosh on phonegap build and i get the error: "Oh geez. Your build failed. Sorry, but a problem occurred on the build server" when trying to build. I tried using: gap:plugin name="com.pushwoosh.plugins.pushwoosh" version="3.4.2" /> gap:plugin name="com.pushwoosh.plugins.pushwoosh" version="3.4.1" /> and both ended up with the same error.

I am using phonegap build with phonegap version of 3.7.0.

Anyone can help? thanks.

asked 22 Oct '15, 16:58
tomermes's gravatar image

tomermes
11

I have the same issue and here is the informations I gathered until now:

  1. This error is, in my case, caused by 2 plugins conflicting each others: pushwoosh-pgb-plugin & cordova-plugin-google-analytics
  2. The error become more explicit if you set a version code for google analytics as "0.7.1" -> "Two of the plugins in your app are incompatible as they both add a file with the same name...View logs to find.."
  3. Errors only happens on android, everything is OK on windows & ios
  4. Despite the error message, the build log is completely clueless, no infos about what is exactly causing this.
permanent link
answered 22 Oct '15, 21:31
Gigme's gravatar image

Gigme
111

This is interesting, but I don't have a google analytics plugin. I have many more plugins, so maybe it's one of them.

(23 Oct '15, 06:04) tomermes tomermes's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×326
×165
×91

question asked: 22 Oct '15, 16:58

question was seen: 752 times

last updated: 23 Oct '15, 06:04