Hi, I had a fine working application (in Unity) with older version of PushWoosh (probably from 12/2014). Now I decided to upgrade to newer version along with Google Play Services and Android Support Library. Upgrade went OK, but now the push messages are not received - every message I send is resulted in MesmatchSenderId error. Except the pushwoosh and mentioned libraries has changed. I've also tried to generate another API key, but it did not help. There's also no error in logcat. Any suggestions? Thanks

asked 19 Jan '16, 16:42
chuckyw's gravatar image

chuckyw
111

Probably it is something connected to project settings in Google console -

I've used the same App_Code and GCM_Project_Number (known as APP1_Settings further) in Pushwoosh Unity Sample App, and it didn't work either. But when I've used another App_Code and coresponding GCM_Project_Number (aka APP2_Settings), it worked like a charm.

Strange thing is, that when I use the APP1_Settings in a project with older Pushwoosh version, everything is OK. (This older version of PushWoosh reads its App_Code and GCM_Project_Number from AndroidManifest.xml)

(20 Jan '16, 07:21) chuckyw chuckyw's gravatar image

Hello

Could you please contact our support at help@pushwoosh.com with that issue? It'd be easier to investigate the problem knowing your username and your application code.

permanent link
answered 20 Jan '16, 07:43
Nikolai's gravatar image

Nikolai
3585

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×446
×88
×7

question asked: 19 Jan '16, 16:42

question was seen: 880 times

last updated: 20 Jan '16, 07:43