Hi,

I'm still using phonegap 2.9.0, so can I use the latest Pushwoosh SDK? I ask this because in the guide the first step is to install plugin source code. If I not mistaken, this step need to do for cordova 3 and above right? So in my case, do i need to install plugin source code? what should I do?

Thanks,

Puah.

asked 21 Jan '14, 09:52
askeypuah's gravatar image

askeypuah
1113

edited 21 Jan '14, 11:08

admin's gravatar image

admin
366

Hi,

Yes you can! Take a look on Phonegap samples (iPhone, Android) here, it will give you idea on how to add plugin source code to the project (basically it is as simple as adding files in XCode project or Eclipse):

https://github.com/shaders/pushwoosh-sdk-samples

There will be one catch for Android as Phonegap 3.0 broke backwards compatibility with 2.9. Please see this thread on how to fix this:

http://community.pushwoosh.com/questions/12/getting-error-in-pushnotificationsjava-while-adding-a-plugin-in-phonegap-android-project

P.S. However I would recommend updating to the latest Phonegap version. They have fixed and updated a lot of things there.

permanent link
answered 21 Jan '14, 10:52
shader's gravatar image

shader
3.9k7

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×190
×165

question asked: 21 Jan '14, 09:52

question was seen: 1,443 times

last updated: 21 Jan '14, 11:08