Hello, I'm having an issue with sending push notifications to firefox browsers. They send just fine in chrome but on firefox I get an error in the notification delivery report: "The pushtoken is not recognized by Mozilla" and the user becomes unsubscribed. There seems to be no issue in the browser console after subscribing.

Details:
Browser: Firefox version 47.0.1
OS: Mac OSX 10.8.5
Test Url: https://puppymaniac.com/

Console output when allowing notifications as a user:
Performing registerDevice call to Pushwoosh with arguments: {"application":"7A414-EF44B","push_token":"https://updates.push.services.mozilla.com/wpush/v1/gAAAAABXnGHuTbmjMMyVMb-n127ghWPs9DTkYVgrR-njMqK2iT6symQIkcBQJWiDXZoSxx6cMJE33lWk81uqKHGSeXTGxqkC85ghQX2QeRNd676W0rTMMv2BnP03_AKI7G4CKN7nZz5z","language":"en-US","hwid":"7A414-EF44B_a5aae7eb34779b1f300e226dd4207676","timezone":25200,"device_model":"Firefox 47","device_name":"PC","device_type":12,"public_key":"BG6308rMiciLGDle9VgeNo508iPoLqNovaM4gslrpqlBNEtgomFECRer+lkoO+yEX/iT5FvQSj+s1UNay+xerh0="}

registerDevice call to Pushwoosh has been successful

Thanks for your time and patience!

asked 30 Jul '16, 09:24
mick's gravatar image

mick
112

edited 30 Jul '16, 09:27

Hi!

May I ask you whether you've integrated our Web Push SDK 2.0:

http://docs.pushwoosh.com/docs/web-sdk-20

It's important to use the latest version so Firefox pushes would function properly!

permanent link
answered 01 Aug '16, 10:43
Nikolai's gravatar image

Nikolai
3585

Hello Nikolai, thank you for taking the time to help. I have updated to the latest SDK and followed the instructions to set it up on my site, however I'm still not able to deliver notifications to the firefox subscriber(no actual firefox users yet just testing by myself).

I have taken the following steps:
-Removed any references to the old service-worker.js from my site.
-Included the manifest link in my header (before any other manifest links).
-Removed my site in firefox notification settings so I will be prompted to allow notifications again.
-Uploaded pushwoosh-service-worker-light.js and pushwoosh-service-worker-dark.js to my site root.
-Included the code in my site header as per the sdk 2.0 documentation(adjusting applocationCode variable etc as necessary)
-Clear the cache in firefox browser and cloudflare, verified new code is in place via "view source".
-Visit my site on firefox, get prompted to allow notifications and select "always allow notifications".
-Log into pushwoosh control panel, I show as a new subscriber okay.
-Send pushwoosh to firefox only to test but the new firefox subscriber gets removed and the notification never delivers.

Thank you so much again for your time in helping me with this issue.

permanent link
answered 01 Aug '16, 14:17
mick's gravatar image

mick
112

Hey again!

May I ask you to try to re-subscribe to the notifications? That should help.

permanent link
answered 03 Aug '16, 05:18
Nikolai's gravatar image

Nikolai
3585

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×446
×91
×6

question asked: 30 Jul '16, 09:24

question was seen: 912 times

last updated: 03 Aug '16, 05:18