Re-registering device on iOS has no effect. Steps to reproduce:

  1. call registerForPushNotifications (device is visible on dashboard counter and it's receiving notifications)
  2. call unregisterForPushNotifications at some point
  3. call registerForPushNotifications again
  4. Result: device is never registered again until user uninstalls the app. Device doesn't appear on pushwoosh dashboard, and there is no "registerDevice" API call in console logs. Device is not receiving notifications as well.
asked 29 Sep '16, 11:17
dev_tool's gravatar image

dev_tool
113

edited 29 Sep '16, 11:20

Have you fixed it,please?

permanent link
answered 10 Oct '16, 19:52
iaio81's gravatar image

iaio81
111

Same bug for me with last version of Phonegap and last version of Pushwoosh plugin (@6.2.2) Unfortunately I didn't found a fix yet.

permanent link
answered 11 Oct '16, 10:16
adrian's gravatar image

adrian
111

Same bug for me too (ios native).

permanent link
answered 19 Oct '16, 12:41
ncherniavskaya's gravatar image

ncherniavskaya
113

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×352
×76
×21

question asked: 29 Sep '16, 11:17

question was seen: 1,390 times

last updated: 19 Oct '16, 12:41