Hi, I stay on PushWoosh SDK 4.12.2 when u released 5.0 version and now i get exception

Caused by: java.lang.StringIndexOutOfBoundsException: length=0; index=1 at java.lang.String.substring(String.java:1897) at com.pushwoosh.internal.utils.a.(Unknown Source) at com.pushwoosh.internal.utils.a.a(Unknown Source) at com.pushwoosh.fragment.PushFragment.registerReceivers(Unknown Source) at com.pushwoosh.fragment.PushFragment.register(Unknown Source) at com.pushwoosh.fragment.PushFragment.onCreate(Unknown Source)

I don't want to update to 5.0 version, can i fix it somehow?

https://github.com/Pushwoosh/pushwoosh-android-sdk/issues/56

asked 04 Jul, 06:51
Justix's gravatar image

Justix
112

edited 04 Jul, 06:52

Close issue I don't feel

@string/PW_APPID and @string/PW_PROJECT_ID

for flavors i build app with , sry

permanent link
answered 04 Jul, 07:51
Justix's gravatar image

Justix
112

edited 04 Jul, 08:06

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×434
×90
×28

question asked: 04 Jul, 06:51

question was seen: 206 times

last updated: 04 Jul, 08:06