Hello!

We integrated the Pushwoosh SDK for iOS and get a PushToken after registration. If we send a notification from the Pushwoosh interface, there is no notification shown on the phone.

We enabled push-notifications in the provisioning-profile and also on the iphone. What can we do, to solve this problem?

We use PhoneGap for developing.

Thank you for your help!

asked 02 May '14, 06:38
HelmelAn's gravatar image

HelmelAn
214

edited 02 May '14, 06:40

You should go through the very standard checks for iOS:

  1. Is my profile push compatible? The app should display "allow push notifications" alert on start (at the very first launch only!). Provisioning profile should have "aps-environment" string it in.
  2. Do I use correct push notifications gateway? The gateway should match the provisioning profiles. Sandbox for development profiles and Production for AdHoc and AppStore builds.
  3. Maybe my wi-fi router blocks APS ports? Wi-Fi will need to allow inbound and outbound TCP packets over port 5223.
  4. Reboot the device. have you tried turning it off and on again.
  5. What does the status of the push on "Pushes" page display?
permanent link
answered 04 May '14, 14:50
shader's gravatar image

shader
3.9k7

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×446
×353
×165

question asked: 02 May '14, 06:38

question was seen: 2,283 times

last updated: 04 May '14, 14:50