I am having trouble with my native iOS app, as it can only show push notifications when the app is open. If in background mode no notifications will show. Not even when i open the app. So it is not like they are queued up. I have tried to follow this guide, https://community.pushwoosh.com/questions/542/ios-no-notification-shown, but have not been able to locate the error. Any suggestions?

asked 09 Jun '14, 10:05
Perviking's gravatar image

Perviking
1013

Have you selected the correct alert style in Settings -> Notification Center -> Your app?

alt text

permanent link
answered 10 Jun '14, 13:52
Fectum's gravatar image

Fectum
2604

Yes, i found out what the issue was. In the iOS app we had implemented at 'enable/disable' push notification checkbox. When this got turned On/Off the settings in the notification centered changed to permanently exclude 'banners'. So the notification only worked in the app afterwards. We fixed this by removing this feature and wrote text that explained how to disable it in the 'Notification center'. Any idea why this happened?

permanent link
answered 10 Jun '14, 14:05
Perviking's gravatar image

Perviking
1013

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×353
×141
×111

question asked: 09 Jun '14, 10:05

question was seen: 2,205 times

last updated: 10 Jun '14, 14:05